Fast delivery within 72 Hours

SIP SIP-T58W Pro

£296.84

Excl.VAT

SKU: 1301113 Category: Brand:

Out of stock

Shipping & Delivery

  • Standard delivery

Our courier will deliver to the specified address

3-4 Days

From £9.95

  • Express delivery

All heavy items above 25kg will be charged shipping cost as per actual

1-2 Days

From £14.95

7″ LCD, Wi-Fi, USB 2.0, Bluetooth, 1G LAN, RJ-9, PoE, Android 9.0, 259.4x220x215 mm

Free from Cord Constraint, Free from Distracting Noise

Adopting the innovative Bluetooth handset, Yealink T58W Pro pervades wireless communication by allowing the user to move around freely and conveniently.

The professional hardware and the cutting-edge acoustic algorithm of Yealink makes the T58W Series an expert at eliminating noise and keeping every conversation clear and focus.

Take Smart Business Phone to the Next Level
Boost by the upgraded chipsets, the T58W Series comes with enhanced system performance with fast response and reinforced processing capacity. The adoption of Android 9.0 OS also improves the data encryption, authority management, response speed and integratability to meet requirements of modern business and future sustainability.

Enterprise-level Security, Provision and Management
Taking data security as one of the most significant concerns, the new set of phones adopt Arm TrustZone technology to safeguard various ARM-based data and applications.

By supporting Yealink/Unify Square Device Management Platform, the management, provision and update of the T58W Series can be implemented in a streamlined and simplified manner.

Audio

Adaptive jitter buffersYes
Automatic gain controlYes
Comfort noise generation (CNG)Yes
Microphone muteYes
Noise reductionYes
Packet loss concealment (PLC)Yes
SpeakerphoneYes
Voice activity detectionYes
Voice codecsG.711a, G.722, G.723.1, G.726, G.729, G.729A, G.729B, iLBC

Design

Handset typeWireless handset
Product colourGrey
Product typeIP Phone
Wall mountableYes

Display

DisplayLCD
Display diagonal7 "
Display resolution1024 x 600 pixels
TouchscreenYes
Touchscreen typeCapacitive

Management features

Integrated voicemailYes
Keypad number of keys27
Number of function keys7

Network

BluetoothYes
Bluetooth version4.2
Ethernet LANYes
Ethernet LAN data rates1000 Mbit/s
Ethernet LAN interface typeGigabit Ethernet
Networking standardsIEEE 802.11a, IEEE 802.11b, IEEE 802.11g, IEEE 802.11n, IEEE 802.1x, IEEE 802.3af
Quality of Service (QoS) supportYes
Security algorithms256-bit AES, HTTPS, TLS, WPA2, WPA3
Supported network protocolsIPv4/IPv6, SIP v1 (RFC2543), v2 (RFC3261), UDP/TCP/DNS-SRV (RFC 3263)
Wi-FiYes
Wi-Fi standards802.11a, 802.11b, 802.11g, Wi-Fi 4 (802.11n)

Operational conditions

Operating relative humidity (H-H)10 - 95 %
Operating temperature (T-T)0 - 40 °C

Packaging content

Number of handles included1 pc(s)

Performance

Dual-Tone Multi-Frequency (DTMF) modesIn-band, Out-of band, SIP info

Phone features

Anonymous callYes
Anonymous call rejectionYes
Answering machineYes
Call forwardingYes
Call holdYes
Call parkYes
Call pick upYes
Call returnYes
Call transferYes
Call waitingYes
Caller IDYes
Conference callYes
Do not disturb functionYes
Full duplexYes
IntercomYes
Message-waiting indicator (MWI)Yes
Phonebook capacity1000 entries
RedialingYes
Speed diallingYes

Ports & interfaces

Ethernet LAN (RJ-45) ports2
RJ-9 ports quantity2
USB 2.0 ports quantity2

Power

Power over Ethernet (PoE)Yes

Vendor information

Brand NameYealink
Warranty2 Year(s)

Video

Video codecsH.264 High Profile, H.264, VP8
Video resolutions1280 x 720 pixels
0 reviews
0
0
0
0
0

There are no reviews yet.

Be the first to review “SIP SIP-T58W Pro”

Your email address will not be published. Required fields are marked *

You have to be logged in to be able to add photos to your review.

Specification

Overview

Processor

Display

RAM

Storage

Video Card

Connectivity

Features

Battery

General

Description

7″ LCD, Wi-Fi, USB 2.0, Bluetooth, 1G LAN, RJ-9, PoE, Android 9.0, 259.4x220x215 mm

Free from Cord Constraint, Free from Distracting Noise

Adopting the innovative Bluetooth handset, Yealink T58W Pro pervades wireless communication by allowing the user to move around freely and conveniently.

The professional hardware and the cutting-edge acoustic algorithm of Yealink makes the T58W Series an expert at eliminating noise and keeping every conversation clear and focus.

Take Smart Business Phone to the Next Level
Boost by the upgraded chipsets, the T58W Series comes with enhanced system performance with fast response and reinforced processing capacity. The adoption of Android 9.0 OS also improves the data encryption, authority management, response speed and integratability to meet requirements of modern business and future sustainability.

Enterprise-level Security, Provision and Management
Taking data security as one of the most significant concerns, the new set of phones adopt Arm TrustZone technology to safeguard various ARM-based data and applications.

By supporting Yealink/Unify Square Device Management Platform, the management, provision and update of the T58W Series can be implemented in a streamlined and simplified manner.

Customer Reviews

0 reviews
0
0
0
0
0

There are no reviews yet.

Be the first to review “SIP SIP-T58W Pro”

Your email address will not be published. Required fields are marked *

You have to be logged in to be able to add photos to your review.